[DRBD-user] drbd 8.2.1 partially hanging when writing lots of data

Michael Nelson mikenel at gmail.com
Wed Dec 26 06:05:20 CET 2007

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

I have just set up DRBD 8.2.1 and am trying it out on Linux 2.6.18 (Xen
3.1.0 Dom0) over a gigabit ethernet with ext3. The source machine is a
Pentium 4 w/ 512MB of RAM, the target is an AMD Athlon XP 3200+ w/ 1GB of
RAM. Both machines use Intel PRO/1000 MT NICs.

I am having problems when writing large amounts of data to the drbd device.
If I write, say, 250MB of data (using dd or perl) in one shot, there are no
hangs and I get pretty reasonable performance (~40MB/sec). If I do that
multiple times within a 5-6 seconds of each other, or I write a lot of data
(1GB) in one shot, the writes take 2x-10x times longer, with intermittent
disk activity on the target (it's not sitting there waiting for the disk).
Once or twice it has hung so bad, that I've had to reboot both boxes.

I've looked at netstat -s, and there don't appear to be issues with TCP
retransmissions. When in this state, I have tried to force resync the target
(forced overwrite), but /proc/drbd eventually showed both systems stalled
for good.

I have tried both protocol B and protocol C and end up with the same basic

I have modified the various performance knobs in drbd.conf as follows:
   sndbuf-size (default)
   max-buffers 40000
   unplug-watermark 128
   rate 100M
   al-extents 3833

I have just one resource setup thus far.

Any ideas? If you need any more information, I will be happy to send it.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20071225/f416a043/attachment.htm>

More information about the drbd-user mailing list