[DRBD-user] Kernel Dump / Invalid Null Pointer drbd 0.7.23 together with vServer

Oliver Welter mail at oliwel.de
Mon Apr 23 09:57:54 CEST 2007

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi Lars

>> Worked fine the last year, now after the update I get kernel oopes when 
>> I try to send the device to secondary state - the whole mount operation 
>> is executed in the virtual context of the guest - running it on the root 
>> host works fine.
> then my guess is that either that patch breaks/changes
> something fundamentally, and drbd would need to be adjusted to match
> that change, or you did something stupid and compiled drbd against
> a non-matching kernel, causing the drbd module and your kernel to be
> ABI incompatible, and for some reason the safety net of insmod does
> not catch the ABI incompatibility and loads it anyways.

Hmm, I didnt go to deep into the stuff but the two patches dont seem to
conflict. An ABI incomp is impossible as I am running an non-modular
kernel and patched the kernel tree directly.

Do you have any hints on how to debug ? I tried 0.8. yesterday and that
seems to work...this will harden the migration but if we cant fix it
fast I guess I will upgrade



Diese Nachricht wurde digital unterschrieben
oliwel's public key: http://www.oliwel.de/oliwel.crt
Basiszertifikat: http://www.ldv.ei.tum.de/page72
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5146 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20070423/dbc8017b/attachment.bin>

More information about the drbd-user mailing list