[DRBD-user] Invalid SGL issues with mpt driver

Francis I. Malolot francis_m at proware.com.tw
Mon May 22 12:59:07 CEST 2006

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Dear Kilian,

Our server here had been running DRBD with a terabyte of data
using MPT base driver  for about a year, unfurtunately we haven't
encountered your problem. Please make sure this module is running:


Also make sure to use terminator. If would say its perfectly a HARDWARE ISSUE
or your SCSI driver.

PLease check...

FingerPrint:3082 0CB4 0609 2A86 4886 F70D 0107 02A0
----- Original Message ----- 
From: "Kilian CAVALOTTI" <kilian.cavalotti at lip6.fr>
To: <drbd-user at linbit.com>
Sent: Monday, May 22, 2006 6:44 PM
Subject: [DRBD-user] Invalid SGL issues with mpt driver

Hi all,

I know that's perhaps not the right place to ask, but the weird problem I
encounter really seems to be DRBD related.

I use an external disk array, attached to a SCSI HBA (LSI Logic U320, using
mpt 2.6.16 kernel driver). This enclosure exports a large SCSI volume
(/dev/sda), used as a DRBD device. The problem is that, after some time
synchronizing, I get the following errors :

mptbase: ioc0: IOCStatus(0x0003): Invalid SGL
mptbase: ioc0: LogInfo(0x11070000): F/W: DMA Error
mptbase: ioc0: LogInfo(0x11070000): F/W: DMA Error
mptbase: ioc0: IOCStatus(0x004b): SCSI IOC Terminated

At first sight, it seems to be a SCSI problem, due to the controller, or the
device. But the fact is that these messages only appear when the device is
used as /dev/drbd0. I tried to directly mount /dev/sda and perform intensive
I/O on it (bonnie++, dd), and I also tried to create software RAID1 volumes
(using mdadm) with individual disks of the array (to be sure that all sectors
will be written), and I never got any error. So I think I could say that the
hardware is not in cause.

When the problem occur, I get no DRBD error, only this "Invalid SGL", and the
syncing continue.

Here my drbd.conf relevant part (the problematic host is 'achab'):
resource r0 {
  protocol C;
  incon-degr-cmd "echo '!DRBD! pri on incon-degr' | wall; sleep 60; halt -f";
  startup {
  disk {
    on-io-error   detach;
  net {
  syncer {
    rate 500M;
    group 1;
    al-extents 257;
  on achab {
    device     /dev/drbd0;
    disk       /dev/sda;
    meta-disk  internal;
  on moby {
    device    /dev/drbd0;
    disk      /dev/sda;
    meta-disk internal;
The DBRD module is version v0.7.18, provided by debian source package.

Is this a know problem? Does somebody else observe the same behavior? Is there
a way to avoid these errors?

Thanks in advance for any hint,
Kilian CAVALOTTI                      Administrateur réseaux et systèmes
UPMC / CNRS - LIP6 (C870)
8, rue du Capitaine Scott                          Tel. : 01 44 27 88 54
75015 Paris - France                               Fax. : 01 44 27 70 00
drbd-user mailing list
drbd-user at lists.linbit.com

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the drbd-user mailing list