[DRBD-user] DRBD CENTOS Problem

drbd at bathnetworks.com drbd at bathnetworks.com
Sat Jun 24 08:07:23 CEST 2006

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi all,

I've been wrestling with a problem with drdb and centos. I have
successfully created one drbd resource, but when I try the create a 2nd, I
get an error on one of the nodes:

Lower device is already mounted.
Command 'drbdsetup /dev/drbd1 disk /dev/hdd1 internal -1' terminated with
exit code 20

The partition is not mounted from fstab etc and is newly created with
parted after wiping this disk with dd.

On the node with the problem I see:

cat /proc/partitions
major minor  #blocks  name

   3     0   60034968 hda
   3     1     514048 hda1
   3     2    1534207 hda2
   3     3   57986617 hda3
  22     0  120060864 hdc
  22     1  114688003 hdc1
  22    64  117220824 hdd
  22    65  114688003 hdd1
 253     0  117219800 dm-0
 253     1  114688003 dm-1
 147     0  114556928 drbd0

On the other node the dm-0 and dm-1 do not occur. Being new to Linux, I am
not sure where these come from. I have tried google, but nothing makes
sense.  This maybe a red herring, but dm-1 has the same number of blocks
as hdd1 which I am trying to mount so I'm guessing that this is the cause
of the problem.

As I have tried changing every thing I can except the mb/processor and
reinstalling, I'm really stuck.

HELP Please.


More information about the drbd-user mailing list