[DRBD-user] Re: can't seem to create meta data

dp dp7885 at yahoo.com
Mon Jul 31 15:41:46 CEST 2006

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Milind Dumbare wrote:
> On Sun, 2006-07-30 at 22:33 -0500, dp wrote:
>> Hi,
>> I've tried to build drbd 8.0pre3 against the latest fedora core 5 kernel 
>> (want to try primary/primary.  Things seem to build ok.  So I install 
>> it, modprobe it, then try and do a drbdadm up all...
>> It tells me there's no meta data and to do drbdadm create-meta drbd0 (my 
>> resource name).  It sits there for a bit with a nice little progress 
>> meter and finally says it's ok.  Try the drbdadm up all again and it 
>> tells me the same thing about no meta data.  When I try and do the 
>> create again, it tells me it's already there do I want to overwrite it.
> If you are creating metadata for the first time, you can overwrite
> whatever underlying. Hope you don't have any data on that device.
>> Any ideas what I'm doing wrong.  I've tried it with an meta-disk 
>> internal and meta-disk /dev/sda1[0];  same results.
>> By the way I'm trying this on a USB drive. Does that matter?
> AFAIK, it shouldn't matter.
>> _______________________________________________
>> drbd-user mailing list
>> drbd-user at lists.linbit.com
>> http://lists.linbit.com/mailman/listinfo/drbd-user

i guess, i didn't explain this properly... what seems to be happening is 
  that drbdadm and drbsetup don't seem to recognize that metadata has 
been created on the drive.  doesn't matter how many times i go through 
the cycle, the metadata is never recognized

More information about the drbd-user mailing list