[DRBD-user] can't seem to create meta data

dp dp7885 at yahoo.com
Mon Jul 31 05:33:11 CEST 2006

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.


I've tried to build drbd 8.0pre3 against the latest fedora core 5 kernel 
(want to try primary/primary.  Things seem to build ok.  So I install 
it, modprobe it, then try and do a drbdadm up all...

It tells me there's no meta data and to do drbdadm create-meta drbd0 (my 
resource name).  It sits there for a bit with a nice little progress 
meter and finally says it's ok.  Try the drbdadm up all again and it 
tells me the same thing about no meta data.  When I try and do the 
create again, it tells me it's already there do I want to overwrite it.

Any ideas what I'm doing wrong.  I've tried it with an meta-disk 
internal and meta-disk /dev/sda1[0];  same results.

By the way I'm trying this on a USB drive. Does that matter?

More information about the drbd-user mailing list