[DRBD-user] Unreadable DRBD directory - Solved

Todd Denniston Todd.Denniston at ssa.crane.navy.mil
Tue Jan 10 14:50:01 CET 2006

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Jonathan Soong wrote:
> SELinux at fault
> Disabled it and it worked fine

Out of curiosity, I am wondering if you replaced /var/www with a soft link to 
/data/drbd and reset your DocumentRoot back to /var/www if it would work 
correctly with SELinux on, or if you would need to modify 
/etc/selinux/targeted/contexts/files/file_contexts (the only place in the 
/etc/selinux directory tree I found the word apache) to point to /data/drbd 
and then re-run some selinux config tool.

Please note: about changing the SELinux config, I have never modified SELinux 
configs other than to set SELinux only to warn on install, and you would 
_probably_ be safer using system-config-securitylevel to "Disable SELinux 
protection for httpd daemon" under the heading "HTTPD Service" than to just 
have it turned off for everything.

> Jonathan Soong wrote:
>> I have a really strange problem.
>> Drbd: 0.7.15
>> Fedora Core 4
>> I mount my drbd partition on /data/drbd and it works fine - I can 
>> create and delete files in it.
>> Next I set my DocumentRoot in Apache to /data. Apache works fine, but 
>> it cannot see the /data/drbd partition (it does not display it in the 
>> directory listing)
>> If I try to set my DocumentRoot to /data/drbd, Apache fails to start 
>> altogether (no error messages).
>> I've tried recreating the file system, but it doesn't seem to be a FS 
>> problem (i can create and delete files fine).
>> Any help would be most appreciated.
>> Cheers
>> Jon

More information about the drbd-user mailing list