[DRBD-user] Unreadable DRBD directory

Jonathan Soong jon.soong at imvs.sa.gov.au
Tue Jan 10 02:17:07 CET 2006

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

I have a really strange problem.

Drbd: 0.7.15
Fedora Core 4

I mount my drbd partition on /data/drbd and it works fine - I can create 
and delete files in it.
Next I set my DocumentRoot in Apache to /data. Apache works fine, but it 
cannot see the /data/drbd partition (it does not display it in the 
directory listing)
If I unmount /data/drbd, Apache DOES see the (now empty) directory.
I'm sure its not a permission problem (i've tried changing owner of all 
files to the Apache user and have also tried 'chmod 777'ing everything).

If I try to set my DocumentRoot to /data/drbd, Apache fails to start 
altogether (no error messages).

Would there be any reason for Apache not being able to see the DRBD 
directory? Is there any tool to check the /data/drbd partition.

Mount shows:
$> /dev/drbd0 on /data/drbd type ext3 (rw)

Stat shows:
[root at iha3 ::IHA3-DELL::ha.d]# stat /data/drbd
  File: `/data/drbd'
  Size: 4096            Blocks: 8          IO Block: 4096   directory
Device: 9300h/37632d    Inode: 2           Links: 4
Access: (0777/drwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2006-01-10 11:34:12.000000000 +1030
Modify: 2006-01-10 09:18:58.000000000 +1030
Change: 2006-01-10 11:36:39.000000000 +1030

I've tried recreating the file system, but it doesn't seem to be a FS 
problem (i can create and delete files fine).

Any help would be most appreciated.



More information about the drbd-user mailing list