[DRBD-user] Cannot recover from split brain :(

Vitaly Kuznetsov vitty at ruir.com
Fri Dec 1 15:19:22 CET 2006

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

try drbdsetup /dev/drbd0 primary -o

James Vanns wrote:
> In a two-node, primary/primary configuration with drbd-0.8pre6 when both
> nodes have rebooted I have a split-brain situation for some reason. Yet,
> I cannot seem to remedy it!
> Here is what I have tried (and many permutations thereof in
> frustration ;):
> node0: drbdsetup /dev/drbd0 primary
> node1: drbdsetup /dev/drbd0 secondary
> node1: drbdsetup /dev/drbd0 outdate
> Both still in standalone mode now obviously not knowing of each others
> disk state.
> node0: drbdadm disconnect all
> node1: drbdadm disconnect all
> node0: drbdadm connect all
> node1: drbdadm connect all
> node0: drbdsetup /dev/drbd0 invalidate-remote
> node1: drbdsetup /dev/drbd0 invalidate
> As you can see - I've tried to keep node0 primary. The states remain the
> same - even after a node1 reboot again.
> According to my configuration file these should fix themselves up?
> after-sb-0pri discard-younger-primary;
> after-sb-1pri discard-secondary;
> after-sb-2pri disconnect;
> The latter is of course (I think!) what has happened. How can I now
> force one to be primary and the other secondary (or even primary but
> just re-sync and enter a connected state) and begin a re-sync? I don't
> really want to invalidate another one because this means a copy of every
> block from primary to secondary - and they're not (or shouldn't!) be
> that out-of-date!
> Any help appreciated.
> Jim Vanns

More information about the drbd-user mailing list