[DRBD-user] Re: [Ocfs2-users] OCFS2 over DRBDv8

Kilian CAVALOTTI kilian.cavalotti at lip6.fr
Fri Aug 18 12:19:43 CEST 2006

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On Thursday 17 August 2006 19:55, Sunil Mushran wrote:
> As far as ocfs2 is concerned, bio_add_page() is failing. The one thing
> that springs to mind is that o2hb sets bio->bi_sector to 512 bytes and
> not the block size.

How could I check if that's the case?
I tried to format the device with different block sizes, with no better 
result. And I also tried to OCFS2-format the DRBD underlying device to be 
sure it was not a hardware-related problem, and it mounts without any 

To sum-up my current setup:
/dev/drbd0 is defined as:
  on moby {
    device    /dev/drbd0;
    disk      /dev/md2;
    flexible-meta-disk internal;
/dev/md2 is a RAID0 MD device, 2.5TB in size, assembled from two ICP Vortex 
SATA-RAID cards [1] 

Even in (DRBD) disconnected mode, starting the OCFS2 cluster services and 
formatting the device does not allow to mount it.

moby:~# cat /proc/drbd
version: 8.0pre4 (api:84/proto:82)
SVN Revision: 2375M build by root at moby, 2006-08-17 15:54:17
 0: cs:WFConnection st:Primary/Unknown ds:UpToDate/DUnknown r---
    ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0
        resync: used:0/7 hits:0 misses:0 starving:0 dirty:0 changed:0
        act_log: used:0/257 hits:0 misses:0 starving:0 dirty:0 changed:0
moby:~# mkfs.ocfs2 -T mail -L ocfs2_cluster /dev/drbd0
mkfs.ocfs2 1.2.1
Filesystem Type of mail
Filesystem label=ocfs2_cluster
Block size=4096 (bits=12)
Cluster size=65536 (bits=16)
Volume size=2700219121664 (41202074 clusters) (659233184 blocks)
1278 cluster groups (tail covers 11162 clusters, rest cover 32256 clusters)
Journal size=268435456
Initial number of node slots: 4
Creating bitmaps: done
Initializing superblock: done
Writing system files: done
Writing superblock: done
Formatting Journals: done
Writing lost+found: done
mkfs.ocfs2 successful
moby:~# mount -t ocfs2 /dev/drbd0 /data
ocfs2_hb_ctl: I/O error on channel while starting heartbeat
mount.ocfs2: Error when attempting to run /sbin/ocfs2_hb_ctl: "Operation 
not permitted"

The whole previous operation works flawlessly if applied on /dev/md2 rather 
than /dev/drbd0.


[1] http://www.icp-vortex.com/english/product/pci/rz_sata_8/8586rz_e.htm
Kilian CAVALOTTI                      Administrateur réseaux et systèmes
UPMC / CNRS - LIP6 (C870)
8, rue du Capitaine Scott                          Tel. : 01 44 27 88 54
75015 Paris - France                               Fax. : 01 44 27 70 00

More information about the drbd-user mailing list