[DRBD-user] GLIBC error

Discussion Lists discussions at lagraphico.com
Thu May 19 19:39:14 CEST 2005

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

I get this error when running the init script or the drbdadm command:

Drbdadm: relocation error: drbdadm: symbol gnu_dev_minor, version
GLIBC_2.3.3 not defined in file libc.so.6 with link time reference.

Okay so here's the whole story.  I have a locked down machine that has
zero development environment, and I have a dev machine that has a dev
environment.  I am trying to compile DRBD on the dev machine, and copy
all of its stuff appropriately over to the secure machine so I can run
it there.  Each of the machines are at the same kernel-level, and most
of everything DRBD seems to work so far on each machine.  For intance
modprobe drbd works fine.  Also if I do a /etc/init.d/drbd start, that
will start everything up, but there will be an error very close to the
one above.  /etc/init.d/drbd state will show that it is working.
/etc/init.d/drbd stop will error out, and I can't actually stop drbd.
/lib/libc.so.6 is actually a link to /lib/libc-2.3.2 on the secure

I have tried to copy over libc-2.3.3 from another machine, and re-link
libc.so.6 to it.

Result= none of the binarys would work anymore.

I have also tried to copy libc-2.3.2 from the dev machine to the secure
machine to replace the existing file.

Result= Total system hang.

Thank God for Vmware.

Those are the main things I have tried to do with no success, and I was
hoping someone would have some advice.  I can't install a development
environment on the secure machine though, so I am limited with what I
can do there.  I was hoping some of you could tell me what the error
means, and some way to get around it, or fix it?


More information about the drbd-user mailing list