[DRBD-user] [FIXED] File data corrupt when I switch Nodes

Lars Ellenberg Lars.Ellenberg at linbit.com
Mon Sep 27 13:57:31 CEST 2004

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

ok, to summarize this thread, it started with:

/ 2004-08-31 09:34:04 +0100
\ Kevin Izzet:
> Hi All,
> Firstly can I thank Philipp, Lars and everyone else who has
> contributed to DRBD, we have been running a production cluster
> for over a year now supporting :
> Unix/Linux Home accounts
> Unix/Linux Application serving
> Apache
> Samba
> My issue is I am in the process of building a second cluster
> with the following spec
> HP DL380 G3's
> 2 Gb RAM
> Gigabyte Ethernet for Replication
> Serial for Heartbeat
> Suse 9.0 prof ed, stripped down for server use only....
> Kernel Suse 2.4.21-99-smp4G.
> 1 x 72GB 15k rpm drive for root
> 2 x 72GB 15k rpm drive stripped to 135.6GB for drbd replication.
> Heartbeat 1.2.2
> The server will be running Samba3 and Postgresql 7.4.3
> (and 8.0beta for testing)
> I originally installed drbd 0.6.12 which worked perfectly and
> has been running for a couple of weeks without any issues, but
> after the release of 0.7.3 I decided to bite the bullet and give
> it a go.

and with 0.7.3 on said Suse kernel 2.4.21-99-smp4G, it corrupted
data while mirroring. so original data was ok, but data on the
secondary was corrupt and did not work at all.

meanwhile, someone paid linbit to install drbd 0.7 on a SLES8, and
that was when we noticed some bad behaviour of the (until then
mostly untested) drbd 0.7 compatibility code path for 2.4. kernels
in conjunction with SuSE 2.4 kernel and highmem.
(kernel.org would have worked).

the bug (completely bogus page offset calculation) showed only
with 2.4. vendor kernel (suse or similar), plus highmem and more
than 1GB ram actually installed.

this fix lead to drbd 0.7.4. 

and Kevin finally confirms that it now works for him again, too:

/ 2004-09-27 12:08:06 +0100
\ Kevin Izzet:
> Hi Lars/Philipp
> Finally found the time to try out the 0.7.4 version on our Suse 9.0
> Dev Cluster and the results are perfect, I can now switch
> between nodes without any data corruption (using a Stock SUSE
> 2.4 Kernel).
> Unfortunately I can't move to a 2.6 kernel yet as we use FDDI
> cards for the public network and the driver for these isn't
> supported on 2.6, but at least I can upgrade from our 0.6.12
> cluster on Redhat 7.2 to Suse 9.0 and drbd 0.7.4 and still sleep
> at night.....
> Thanks for all the hard work......
> Regards
> Kevin Izzet

	Lars Ellenberg

please use the "List-Reply" function of your email client.

More information about the drbd-user mailing list