[DRBD-user] DRBD 0.6.13 on 2.4.24

P.V.Anthony pvantony at singnet.com.sg
Mon Sep 13 05:14:30 CEST 2004

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.


I am having some problems with version 0.6.13 on 2.4.24. Whenever I try
to sync up, the secondary node will hang.

Some details first.

Linux: Fedora Core 1
Kernel: 2.4.24 source from http://www.kernel.org
CPU: Intel P4
Motherboard: Supermicro P4SCT+
Drives: Sata Drives on Marvell Controllers
Network: Intel Gigabit
Raid: Software Raid 1
FileSystem: ext3

Here is want I did and please see if they are alright.

0. Waited for all software raid to sync up.
1. Tried to "service drbd start" (version 0.6.13) on both servers
2. cluster 2(secondary) will hang
3. Tried drbd again but this time cluster 1(secondary)
4. cluster 1 (secondary) will hang. So the seconadry will always hang.
5. next I tried a old version of drbd 0.6.10 but same results
6. next I recompiled the kernel without hi-mem IO (read in maillist)
7. same results
8. Then I tried 0.7.4 (solved the hi-mem IO problem) and it works well.
9. Tried many restarts and it still works well.
10. Next I tried openmosix with migration on and it works well.

So I do not think it is a hardware problem.

Please comment. Have I missed out any other thing? Is there any other
test I can do?

Is there any patch for 0.6.13 so that it will not hang the kernel? I am
sorry for assuming that it is a 0.6.13 problem. I am a newbie and I
cannot think of any other reason.

The reason why I want to use 0.6.13 is because I am using TKCluster from

Please do assist.


More information about the drbd-user mailing list