[DRBD-user] Upgrade issues from 0.7.5 to 0.7.6

Kevin Izzet Kevin.Izzet at nsc.com
Tue Nov 30 13:08:29 CET 2004

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi all,

Trying to upgrade from 0.7.5 to 0.7.6 having  followed instructions for 
building drbd as per usual but when  try to restart
drbd I get the following error :-

Starting DRBD resources:    max-buffers 4096 => 4096 out of range [32..32]
Command '/sbin/drbdsetup /dev/drbd0 net C --timeout=60 --connect-int=10 --ping-int=10 
--max-buffers=4096 --max-epoch-size=2048 --ko-count=4 
--on-disconnect=reconnect' terminated with exit code 20
drbdadm aborting

Now I am making the assumption that drbd 0.7.6 is backward compatible with 
0.7.5 so here are the basic steps I'm using
for the upgrade.

1. Shutdown HA services on secondary node
2. Clean and re-create the Kernel source (mrproper,cloneconfig, dep...)
3. make clean all in the drbd src dir
4. cd .. ; make install 
5. drbd start

If the above had worked I would then have

6. Restart HA services on secondary.
7. Stop services on primary forcing them onto secondary.
8. Perform steps 2 - 6 on now secondary server.
9. Job Done !!!!!

I have tried to recover back to 0.7.5 but I get issues over the API and 
Proto Levels being wrong!!

OS  Suse 9.0 Profes.
Kernel 2.4.21-99-smp4G - vanilla Suse Kernel.



This email may contain confidential and privileged material for the sole 
use of the intended recipient. Any review, use, distribution or disclosure 
by others is prohibited. If you are not the intended or authorised 
recipient please contact the sender by reply email and delete all copies 
of this message
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20041130/6835f4b7/attachment.htm>

More information about the drbd-user mailing list