[DRBD-user] Massive slow down - drbd 0.6.12

Lars Ellenberg lars.ellenberg at linbit.com
Thu Jun 24 14:15:30 CEST 2004

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On Wed, Jun 23, 2004 at 03:10:04PM -0700, JD Gray wrote:
> I'm in the process of setting up a heartbeat + drbd cluster. I got drbd 
> working... kinda. I run /etc/init.d/drbd start on both machines, they 
> connect, and begin SyncingAll, at first the sync went at ~250K/s, so, I 
> tweaked the sync-rate to 10M. Now, it runs at the 10 it's supposed to 
> for about 50% of the sync, but then slows down dramatically, back to 
> ~250K/s. I tried using a different network. (Using their internet 
> connection NIC's running through a switch, rather then the heartbeat 
> interface) but I'm having similar results other then the switched 
> network has a much more variable speed when it does work, which is 
> understandable because of their internet connection through that nic. 
> The NIC's involved all use the eepro100 driver, excluding the heartbeat 
> interface NIC on megatron. Here's my drbd.conf (identical on both machines):
> armada / # cat /etc/drbd.conf
> resource drbd0 {
>  protocol=C
>  fsckcmd=fsck.xfs

do you indeed run xfs on drbd 0.6?
this may work (with 0.612).
but it is not expected to perform very well.

you get some "blocksize=.." messages in your syslog?

did you try to increase sync-min ?


More information about the drbd-user mailing list