[DRBD-user] DRBD Setup not working as expected

Norm Dressler ndressler at dinmar.com
Fri Jan 30 20:37:09 CET 2004

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi there,

Prepping two new servers.  Both Dual Xeon P-4's with two Adaptec IDE
RAID (2400A) controllers.  On each I have 4 hard drives, and in hardware
set up two RAID-1's.  They look like /dev/sda1 and /dev/sdb1.  Each
contains a partition that is the full size of the disk.

I am running Mandrake 9.2.  Installed the kernel sources and created a
custom SMP kernel.  The compile of the drbd module worked without a
problem. I can install the drbd module into the kernel and see that two
new devices are created under /dev -- /dev/nb0 and /dev/nb1.

Now I when I run drbdsetup /dev/nb0 disk /dev/sda1 I get an error: can
not open device: No such file or directory.

I have no idea why this is happening and I haven't been able to find
anything online so far.  Anyone have any ideas??


More information about the drbd-user mailing list