[DRBD-user] RPM building problem

Nicolas Bouthors nicolas.bouthors at nbi.fr
Thu Aug 12 17:13:25 CEST 2004

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

I'm sorry, it seems by the archive that a lot of people have trouble
building RPMs from DRBD, and I'm one of those. I searched the list
archives for answer but didn't find anything sufficent.

The context is : I try to package DRBD as an RPM (0.6.13) to go with
standard RedHat 9's kernel 2.4.20-8.

I installed the kernel sources through the package
kernel-2.4.20-8.src.rpm, all the toolchain (make, gcc...) then I tried
several things :

0) Get "vanilla" kernel source from kernel.org, use the Redhat 9
   .config, build kernel with this and then build drbd on these sources.
   This works fine but is not what I want : I want to be able to use
   DRBD as a RPM, with the kernel-2.4.20-8-i686.rpm from redhat (some
   patch included in redhat kernel allows the machine to see an external
   Raid Array that is not seen with vanilla kernel build, go figure)

1) untar DRBD source
   rpm -bb kernel 
   make KDIR=/usr/src/redhat/BUILD/kernel-2.4.20/linux-2.4.20 
   make works fine, when I do a make install the module won't load due
   to unresolved symbols (see below for list)

2) same as 1) but modyfying the drbd_config.h file and uncommenting
   RedHat related stuff (tryed all cobinations of SIGHAND_ACK
   HAVE_O1_SCHED defined or not)

   DRBD builds but still unresolved symbols when modprobing.
3) Tried to edit the drbd.spec minimaly to make rpmbuild happy, tarred
   modified version (SIGHAND_ACK and/or HAVE_O1_SCHED defined) and
   compiled the binary through rpmbuild -bb drbd.spec

   DRBD builds smoothly, the .rpms are created, and installable but
   still unresolved symbols.

4) Tried all the above combinations with fresh subversion checkout, same

5) 'make rpm' simply doesn't work, tries to use subversion to do
   something and crashes (I'm not very familiar with subversion)

Now I'm getting out of ideas and I wonder if anyone has solved this
before. Please help me, this is quite urgent...

Thanks in advance

  Nicolas Bouthors

PS : The unresolved symbols seem to be always the same :

# depmod -ae 
depmod: *** Unresolved symbols in /lib/modules/2.4.20-8/kernel/drivers/block/drbd.o
depmod: 	blk_size_Rsmp_a2e0a082
depmod: 	remove_wait_queue_Rsmp_47525325
depmod: 	sock_recvmsg_Rsmp_5f6d0bda
depmod: 	blk_ioctl_Rsmp_e7800428
depmod: 	fput_Rsmp_5b998cbe
depmod: 	blk_dev_Rsmp_9fe74c8a
depmod: 	blkdev_open_Rsmp_9d147567
depmod: 	register_blkdev_Rsmp_c7d43b79
depmod: 	set_user_nice_Rsmp_0918bc91
depmod: 	__write_lock_failed
depmod: 	blkdev_put_Rsmp_0ddba722
depmod: 	set_device_ro_Rsmp_dc036ebb
depmod: 	blk_queue_make_request_Rsmp_63e6ba18
depmod: 	add_timer_Rsmp_a19eacf8
depmod: 	del_timer_Rsmp_fc62f16d
depmod: 	kmap_high_Rsmp_0c921554
depmod: 	highmem_start_page_Rsmp_a168af88
depmod: 	mod_timer_Rsmp_1f13d309
depmod: 	__out_of_line_bug_Rsmp_8b0fd3c5
depmod: 	tasklist_lock_Rsmp_1d1990ec
depmod: 	create_proc_entry_Rsmp_204db7b2
depmod: 	get_super_Rsmp_c4d765a3
depmod: 	complete_Rsmp_136eba7c
depmod: 	refile_buffer_Rsmp_10e90cda
depmod: 	set_bh_page_Rsmp_0d9971be
depmod: 	kunmap_high_Rsmp_7f683bd0
depmod: 	__run_task_queue_Rsmp_3889b11c
depmod: 	filp_open_Rsmp_53182856
depmod: 	daemonize_Rsmp_d66a354a
depmod: 	add_wait_queue_Rsmp_7f975897
depmod: 	set_blocksize_Rsmp_c75d857c
depmod: 	submit_bh_Rsmp_c41bab6e
depmod: 	sock_create_Rsmp_451f01f5
depmod: 	irq_stat_Rsmp_b3adfd97
depmod: 	_alloc_pages_Rsmp_9e29c837
depmod: 	sock_release_Rsmp_c7fadbef
depmod: 	reparent_to_init_Rsmp_ec6158d0
depmod: 	__vmalloc_Rsmp_79995c5b
depmod: 	sprintf_Rsmp_1d26aa98
depmod: 	schedule_timeout_Rsmp_17d59d01
depmod: 	sock_alloc_Rsmp_0699dfe6
depmod: 	__read_lock_failed
depmod: 	__wake_up_Rsmp_127fda83
depmod: 	remove_proc_entry_Rsmp_4c93b185
depmod: 	printk_Rsmp_1b7d4074
depmod: 	kfree_Rsmp_037a0cba
depmod: 	__wait_on_buffer_Rsmp_110a5c2c
depmod: 	tq_disk_Rsmp_5373dbb6
depmod: 	wake_up_process_Rsmp_0f45e30d
depmod: 	del_timer_sync_Rsmp_daff266a
depmod: 	fget_Rsmp_68043ff4
depmod: 	proc_root_Rsmp_553cac6a
depmod: 	fsync_dev_Rsmp_8ea128e2
depmod: 	wait_for_completion_Rsmp_4abe8112
depmod: 	tqueue_lock_Rsmp_b7a0c0b5
depmod: 	unregister_blkdev_Rsmp_eac1c4af
depmod: 	panic_Rsmp_01075bf0
depmod: 	blksize_size_Rsmp_2f30b4b6
depmod: 	vfree_Rsmp_2fd1d81c
depmod: 	kmalloc_Rsmp_93d4cfe6
depmod: 	schedule_Rsmp_4292364c
depmod: 	__free_pages_Rsmp_02bba2ef
depmod: 	drop_super_Rsmp_b92c35ab
depmod: 	jiffies_Rsmp_0da02d67
depmod: 	kernel_thread_Rsmp_7ca341af
depmod: 	find_task_by_pid_Rsmp_2508ca1f
depmod: 	filp_close_Rsmp_6e02378b
depmod: 	sock_sendmsg_Rsmp_e585a408

Nicolas Bouthors
06 20 71 62 34

More information about the drbd-user mailing list