[DRBD-user] RPM building problem

Lars Ellenberg Lars.Ellenberg at linbit.com
Fri Aug 13 15:13:15 CEST 2004

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

/ 2004-08-13 12:10:18 +0200
\ Lars Ellenberg:
> please use the "List-Reply" function of your email client.
> / 2004-08-13 09:54:44 +0200
> \ Nicolas Bouthors:
> > jeudi 12 août Lars Ellenberg écrivait :
> > >> the kernel source directories you build drbd against do not match the
> > >> configuration of your currently running kernel.
> > >> go fix that.
> > 
> > Tried that, didn't help, still unreseolved symbols.
> sure you tried. but you did not :) so try again.
> and, from your lengthy description in your first mail, you tried several
> things, but you did not follow the steps outlined in INSTALL, did you?

sorry. that was probably not really helpful.
  for the problem with 0.6.13: make rpm failing with "you need a svn
  checkout to do this" (my fault. fixed in the 0.7 series again),
  you can modify the Makefile, line 57:
  -.PHONY: .filelist
  +#.PHONY: .filelist
  that should help.

  but the rpm -bb drbd.spec should just do the same, actually.

  then, read INSTALL.
  specifically the part about "make cloneconfig" ...
  if that still does not help, it is possible that we have a problem
  with redhats handling of "modversions". but I doubt that, since we
  invoke the kernel build system itself, which should know, even though it
  is redhat :^)
  from what you reported I conclude the config of your kernel and kernel
  sources just do not match.

	Lars Ellenberg

More information about the drbd-user mailing list