[DRBD-user] drbd 0.7.2 and /dev/drbd2

Lars Ellenberg Lars.Ellenberg at linbit.com
Thu Aug 12 17:47:53 CEST 2004

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

/ 2004-08-12 10:36:46 -0500
\ Michael Haverkamp:
> I have been using drbd 0.7.2 for about a week now, and it has been 
> working very well with 2 devices (/dev/drbd0, /dev/drbd1).  Today I 
> tried to add a third device (/dev/drbd2), but I have not been able to 
> get it to work.  It complains about /dev/drbd2 (see below).
> # drbdadm adjust all
> can not open /dev/drbd2: No such file or directory
> can not open /dev/drbd2: No such file or directory
> Command '/sbin/drbdsetup /dev/drbd2 disk /dev/myvg/vol2 internal -1 
> --on-io-error=detach' terminated with exit code 20
> drbdsetup exited with code 20
> I noticed that there was no "drbd2" under /dev, so I tried creating one.

hint: module parameter minor_count (defaults to 2)


More information about the drbd-user mailing list