[Drbd-dev] [RFC PATCH 29/34] power/swap: use bio_new in hib_submit_io

Pavel Machek pavel at ucw.cz
Wed Feb 17 23:02:58 CET 2021


Hi!
> 
> diff --git a/kernel/power/swap.c b/kernel/power/swap.c
> index c73f2e295167..e92e36c053a6 100644
> --- a/kernel/power/swap.c
> +++ b/kernel/power/swap.c
> @@ -271,13 +271,12 @@ static int hib_submit_io(int op, int op_flags, pgoff_t page_off, void *addr,
>  		struct hib_bio_batch *hb)
>  {
>  	struct page *page = virt_to_page(addr);
> +	sector_t sect = page_off * (PAGE_SIZE >> 9);
>  	struct bio *bio;
>  	int error = 0;
>  
> -	bio = bio_alloc(GFP_NOIO | __GFP_HIGH, 1);
> -	bio->bi_iter.bi_sector = page_off * (PAGE_SIZE >> 9);
> -	bio_set_dev(bio, hib_resume_bdev);
> -	bio_set_op_attrs(bio, op, op_flags);
> +	bio = bio_new(hib_resume_bdev, sect, op, op_flags, 1,
> +		      GFP_NOIO | __GFP_HIGH);
>  

C function with 6 arguments... dunno. Old version looks comparable or
even more readable...

Best regards,
							Pavel

-- 
http://www.livejournal.com/~pavelmachek
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: Digital signature
URL: <http://lists.linbit.com/pipermail/drbd-dev/attachments/20210217/b7e716df/attachment.pgp>


More information about the drbd-dev mailing list