[Drbd-dev] rename ->make_request_fn and move it to the block_device_operations

Jens Axboe axboe at kernel.dk
Tue Jun 30 15:57:29 CEST 2020

On 6/29/20 1:39 PM, Christoph Hellwig wrote:
> Hi Jens,
> this series moves the make_request_fn method into block_device_operations
> with the much more descriptive ->submit_bio name.  It then also gives
> generic_make_request a more descriptive name, and further optimize the
> path to issue to blk-mq, removing the need for the direct_make_request
> bypass.

Looks good to me, and it's a nice cleanup as well. Applied.

Jens Axboe

More information about the drbd-dev mailing list