[DRBD-user] Proposing a patch for drbd ocf ra to suppress "mismatch" warnings

Raoul Bhatia [IPAX] r.bhatia at ipax.at
Fri Oct 15 15:14:13 CEST 2010

On 09/18/2010 02:16 PM, Raoul Bhatia [IPAX] wrote:
>> Sep 18 13:58:21 node2 lrmd: [21135]: info: RA output: (drbd_db:0:monitor:stderr) DRBD module version: 8.3.7#012   userland version: 8.3.8#012preferably kernel and userland versions should match.
> actually, this is expected but at the same time irritating.
> i found commit c82bc3f73e6a7f14b856471bd6e69d817e6145cc [1] where
> one can set the environment variable DRBD_DONT_WARN_ON_VERSION_MISMATCH
> to suppress such warnings.
> i therefore propose the attach patch to add a new parameter
> warn_on_version_mismatch which defaults to "true"
> when it is set to false, it exports DRBD_DONT_WARN_ON_VERSION_MISMATCH=
> to suppress the warnings.


what about my suggestion? what objections do you have to not apply
it for drbd 8.3.9?

DI (FH) Raoul Bhatia M.Sc.          email.          r.bhatia at ipax.at
Technischer Leiter

IPAX - Aloy Bhatia Hava OG          web.          http://www.ipax.at
Barawitzkagasse 10/2/2/11           email.            office at ipax.at
1190 Wien                           tel.               +43 1 3670030
FN 277995t HG Wien                  fax.            +43 1 3670030 15
-------------- next part --------------
A non-text attachment was scrubbed...
Name: drbd.ocf.patch
Type: text/x-diff
Size: 1070 bytes
Desc: not available
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20101015/f0ab0897/attachment.patch>

More information about the drbd-user mailing list