[DRBD-user] Compile Error Against RackSpace Cloud Linux Kernel

Lars Ellenberg lars.ellenberg at linbit.com
Tue Nov 23 12:39:23 CET 2010


On Tue, Nov 23, 2010 at 01:44:13AM -0500, Sean Carey wrote:
> Folks,
> I am trying to compile the drbd kernel module against the rackspace cloud
> linux kernel and am getting the following error. I followed the online doc
> and I can get the build to work against generic headers, just not RS Cloud.
> Any help would be greatly appreciated.
> 
> 
> The Error:
> 
> test -f ../scripts/adjust_drbd_config_h.sh && \
>  KDIR=/lib/modules/2.6.35.4-rscloud/build O= /bin/bash
> ../scripts/adjust_drbd_config_h.sh
> /lib/modules/2.6.35.4-rscloud/build /usr/src/drbd-8.3.7/drbd
> /usr/src/drbd-8.3.7/drbd


You do realise that 2.6.35 already contains DRBD?

You could try with latest DRBD git (if you want to have a more recent
DRBD than the one shipped with 2.6.35), it should be aware of a few
specialties when building external drbd modules against kernel sources
already containing drbd.

Or just use the one shipped with 2.6.35.

You should use a DRBD userland with the same version as your kernel module.


-- 
: Lars Ellenberg
: LINBIT | Your Way to High Availability
: DRBD/HA support and consulting http://www.linbit.com

DRBD® and LINBIT® are registered trademarks of LINBIT, Austria.
__
please don't Cc me, but send to list   --   I'm subscribed


More information about the drbd-user mailing list