[DRBD-user] RedHat Clustering Services does not fence when DRBD breaks

Joe Hammerman jhammerman at saymedia.com
Fri Nov 19 22:45:06 CET 2010


Hey all, we are attempting to roll out DRBD in our environment. The issue we are encountering is not with DRBD itself but with RHCS. Does the DRBD device need to be defined as a resource in order for it's breaking to trigger fencing? The DRBD nodes are VM's, and the DRBD devices are incorporated into LVM's with GFS2 formatting.

Should I use the DRBD fence-peer handler script to call fence_vm?

Here is the cluster.conf file we are using:

<?xml version="1.0"?>
<cluster alias="studio2.sacpa" config_version="12" name="studio2.sacpa">
        <fence_daemon clean_start="0" post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="studio104.sacpa.videoegg.com" nodeid="1" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="fence_node2"/>
                                </method>
                        </fence>
                </clusternode>
                <clusternode name="studio103.sacpa.videoegg.com" nodeid="2" votes="1">
                        <fence>
                                <method name="1">
                                        <device name="fence_node1"/>
                                </method>
                        </fence>
                </clusternode>
        </clusternodes>
        <fencedevices>
                <fencedevice agent="fence_vmware" ipaddr="10.1.69.105:8333" login="xxx" name="fence_node2" passwd_script="xxx" port="[standard] studio104.sacpa/studio104.sacpa.vmx" vmware_type="server2"/>
                <fencedevice agent="fence_vmware" ipaddr="10.1.69.106:8333" login="root" name="fence_node1" passwd_script="xxx" port="[standard] studio103.sacpa/studio103.sacpa.vmx" vmware_type="server2"/>
        </fencedevices>
        <cman expected_votes="1" two_node="1"/>
        <rm>
                <resources>
                </resources>
                <failoverdomains/>
                  <service autostart="1" name="httpd_drive">
                        <drbd name="drbd-httpd" resource="apache">
                                <fs device="/dev/studio-vg/studio-lv" mountpoint="/export/www/html" fstype="gfs2" name="httpd_drive" options="noatime,nodiratime,data=writeback"/>
                        </drbd>
                        <apache config_file="conf/httpd.conf" name="studio_server" server_root="/etc/httpd" shutdown_wait="0"/>
                </service>
        </rm>
        <dlm plock_ownership="1" plock_rate_limit="0"/>
        <gfs_controld plock_rate_limit="0"/>
</cluster>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20101119/f6f15770/attachment.htm>


More information about the drbd-user mailing list