[DRBD-user] drbd version 8.3.9 or other with kernel > 2.6.35 ?

Lars Ellenberg lars.ellenberg at linbit.com
Sun Nov 7 18:16:43 CET 2010


On Sat, Nov 06, 2010 at 10:37:47AM -0700, fibreraid at gmail.com wrote:
> On Friday, November 5, 2010, Michael <michael.auckland at gmail.com> wrote:
> > On http://www.drbd.org/download/mainline/
> > 2.6.35   -> 8.3.8
> >
> > 2.6.36   -> 8.3.8.1
> >
> >
> > Which kernel version should work with 8.3.9?
> >
> > Tried build with kernel 2.6.35.7 but got an error:
> > ( with ./configure -with-km )

...

> Also I can confirm that compiling drbd 8.3.9 on Ubuntu 10.10
> (maverick) also fails.

Should be fixed with
http://git.drbd.org/?p=drbd-8.3.git;a=commitdiff;h=d23e7fa9dd7c51160761ebcf9fa06a926b042001

For the tracing stuff, just don't compile it for now.
--- a/drbd/Makefile
+++ b/drbd/Makefile
@@ -44,7 +44,7 @@ ifneq ($(PATCHLEVEL),)
   endif

   CONFIG_BLK_DEV_DRBD := m
-  CONFIG_DRBD_TRACE := $(shell test $${SUBLEVEL} -ge 30 && echo m || echo n)
+  CONFIG_DRBD_TRACE := $(shell test $${SUBLEVEL} -ge 30 && test $${SUBLEVEL} -lt 35 && echo m || echo n)

   include $(DRBDSRC)/Makefile-2.6


-- 
: Lars Ellenberg
: LINBIT | Your Way to High Availability
: DRBD/HA support and consulting http://www.linbit.com

DRBD® and LINBIT® are registered trademarks of LINBIT, Austria.
__
please don't Cc me, but send to list   --   I'm subscribed


More information about the drbd-user mailing list