[DRBD-user] drbd version 8.3.9 or other with kernel > 2.6.35 ?

fibreraid at gmail.com fibreraid at gmail.com
Sat Nov 6 18:37:47 CET 2010


Also I can confirm that compiling drbd 8.3.9 on Ubuntu 10.10
(maverick) also fails.

Tommy

On Friday, November 5, 2010, Michael <michael.auckland at gmail.com> wrote:
> On http://www.drbd.org/download/mainline/
> 2.6.35   -> 8.3.8
>
> 2.6.36   -> 8.3.8.1
>
>
> Which kernel version should work with 8.3.9?
>
> Tried build with kernel 2.6.35.7 but got an error:
> ( with ./configure -with-km )
>
>   CC [M]  /usr/src/drbd-8.3.9/drbd/drbd_receiver.o
> /usr/src/drbd-8.3.9/drbd/drbd_receiver.c: In function ‘drbd_submit_ee’:
> /usr/src/drbd-8.3.9/drbd/drbd_receiver.c:1270: error: ‘REQ_UNPLUG’ undeclared (first use in this function)
> /usr/src/drbd-8.3.9/drbd/drbd_receiver.c:1270: error: (Each undeclared identifier is reported only once
> /usr/src/drbd-8.3.9/drbd/drbd_receiver.c:1270: error: for each function it appears in.)
> /usr/src/drbd-8.3.9/drbd/drbd_receiver.c: In function ‘write_flags_to_bio’:
> /usr/src/drbd-8.3.9/drbd/drbd_receiver.c:1816: error: ‘REQ_SYNC’ undeclared (first use in this function)
> /usr/src/drbd-8.3.9/drbd/drbd_receiver.c:1817: error: ‘REQ_UNPLUG’ undeclared (first use in this function)
> /usr/src/drbd-8.3.9/drbd/drbd_receiver.c:1817: error: ‘REQ_BCOMP_SYNC’ undeclared (first use in this function)
> make[4]: *** [/usr/src/drbd-8.3.9/drbd/drbd_receiver.o] Error 1
> make[3]: *** [_module_/usr/src/drbd-8.3.9/drbd] Error 2
> make[2]: *** [sub-make] Error 2
>
> Tried to build 8.3.8.1 (again with ./configure -with-km )
> got different error:
>   CC [M]  /usr/src/drbd-8.3.8.1/drbd/drbd_bitmap.o
> In file included from /usr/src/drbd-8.3.8.1/drbd/drbd_bitmap.c:31:
> /usr/src/drbd-8.3.8.1/drbd/drbd_int.h: In function ‘drbd_md_flush’:
> /usr/src/drbd-8.3.8.1/drbd/drbd_int.h:2512: warning: passing argument 2 of ‘blkdev_issue_flush’ makes integer from pointer without a cast
> /usr/src/drbd-8.3.8.1/drbd/drbd_int.h:2512: error: too few arguments to function ‘blkdev_issue_flush’
> make[4]: *** [/usr/src/drbd-8.3.8.1/drbd/drbd_bitmap.o] Error 1
> make[3]: *** [_module_/usr/src/drbd-8.3.8.1/drbd] Error 2
> make[2]: *** [sub-make] Error 2
>
>
> So should I use module which build inside kernel ( with 2.6.35 it is 8.3.8)?
> is is safe to use userland 8.3.9 with that module?
>
>
> --
> --
> Michael
>


More information about the drbd-user mailing list