[DRBD-user] drbdadm cores when runs from kickstart

Vadym Chepkov vchepkov at gmail.com
Thu May 6 15:54:05 CEST 2010

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On May 6, 2010, at 5:12 AM, Lars Ellenberg wrote:

> On Tue, May 04, 2010 at 09:56:09PM -0400, Vadym Chepkov wrote:
>> Hi,
>> I discovered an unusual problem. I added "drbdadm -- --force create-md all" in kickstart file and it results in segmentation fault.
>> drbd-utils-8.3.7-1.x86_64
>> I managed to collect core file and this is where it is happening:
>> Program terminated with signal 11, Segmentation fault.
>> [New process 1744]
>> #0  find_opt (base=0xcccccccccccccccc, name=0x41af30 "after") at drbdadm_main.c:1400
>> 1400			if (!strcmp(base->name, name)) {
>> (gdb) where
>> #0  find_opt (base=0xcccccccccccccccc, name=0x41af30 "after") at drbdadm_main.c:1400
>> #1  0x0000000000408cc2 in convert_after_option (res=0x18071f30) at drbdadm_main.c:1762
>> #2  0x000000000040db8a in main (argc=5, argv=0x7fff6bd5d488) at drbdadm_main.c:2663
> Your config is referencing some resource in an sync after statement,
> but that resource does not exist.
> We should not segfault there, regardless.
> I think I fixed it in git already some time ago.

Hmm, why would create-md care about "after" ?
At this point even drbd kernel module is not loaded.
It sure doesn't happen if I run it when system is up, only when it is called from  anaconda/kickstart


More information about the drbd-user mailing list