[DRBD-user] Issues with Dell R710 + xenserver 5.6 + drbd 8.3.8.1

Oliver Hoffmann oh at dom.de
Mon Aug 2 18:45:14 CEST 2010


> On Mon, Aug 2, 2010 at 11:54 AM, Oliver Hoffmann <oh at dom.de> wrote:
> 
> > Hi all,
> >
> > I have issues with a xen/drbd setup. The problem here is, that the
> > NIC between the both primary/primary is down for a second once in a
> > while.
> >
> > Jul 29 00:07:07 xen1 kernel: bnx2: eth1 NIC Copper Link is Down
> > Jul 29 00:07:08 xen1 kernel: bnx2: eth2 NIC Copper Link is Down
> > Jul 29 00:07:10 xen1 kernel: bnx2: eth1 NIC Copper Link is Up,
> > 1000Mbps full duplex, receive & transmit flow control ON
> > Jul 29 00:07:10 xen1 kernel: bnx2: eth2 NIC Copper Link is
> > Up,1000Mbpsfull duplex, receive & transmit flow control ON
> >
> > Hence the storage repository can't be accessed any more and so on.
> >
> > At the moment I can't say whether it is a flaw in the driver or HW
> > or cable or whatever.
> >
> > Does some-one had similar problems (with bnx2)? What is the time
> > limit for drbd when a link dies? Does it makes sense to increase
> > that limit?
> >
> >
> What OS are you using?  There was a bug in RHEL/CentOS (and I think
> other OSes, but can't promise that I'm right about that) that was
> just patched. The bug resulted in occasional loss on connectivity on
> network connections using the bnx2 driver.  See
> https://bugzilla.redhat.com/show_bug.cgi?id=587799 for more
> information.
> 
> HTH,
> 
> Ian

Thanks for the hint. xenserver 5.6 is based on centos 5.5. Thus it
might be. I'll try the patch.

Cheers,

Oliver


More information about the drbd-user mailing list