[DRBD-user] Problems updating to 8.3.6 - could not load drbd module

Tobias Appel tappel at eso.org
Thu Nov 26 13:02:49 CET 2009


Hi,

I'm running Scientific Linux (RHEL) and just updated our kernel. Since I 
had to build a new kernel module I thought why not upgrade from 8.3.4 to 
8.3.6.

So I configured drbd with this command:

./configure --prefix=/usr --sysconfdir=/etc --with-km

Then obviously did make and make install - no problems.

Then I did cd drbd and ran make clean all which left me with the drbd.ko 
and it seems fine.

But when I try to start DRBD it says:

Starting DRBD resources: Can not load the drbd module.

When I try to locate drbd.ko it looks like it's in the correct place:

/lib/modules/2.6.18-164.6.1.el5PAE/kernel/drivers/block/drbd.ko
/lib/modules/2.6.18-92.1.22.el5PAE/kernel/drivers/block/drbd.ko

As you can see, the one from before and the one for the new (currently 
running) kernel.

What else could be the problem now? I did the compile and make as root.

Bye,
Tobias


More information about the drbd-user mailing list