[DRBD-user] Errors compiling drbd-8.3.6 on SLES 11

Florian Haas florian.haas at linbit.com
Wed Nov 25 21:45:39 CET 2009


On 11/25/2009 07:07 PM, Roof, Morey R. wrote:
> Hi,
> 
> I'm trying to compile drbd-8.3.6 on SLES 11 and I'm running into some
> errors.  So, the configure script is checking for "/etc/SuSErelease" but
> it is "/etc/SuSE-release", so that should be fixed.

We'll fix that, thank you.

>  There are more
> errors but I haven't finished hunting them down yet.  Will post more as
> I figure it out.

Well if the distro autodetection magic is faulty, then it's relatively
logical that configure probably won't set up DRBD ideally for your system.

Please build with ./configure --with-distro=suse for the time being. If
you still run into build errors even after specifying that flag, please
let us know.

And, please build from a current git checkout. Just so we can rule out
that you're running into errors already fixed upstream. Thanks!

Cheers,
Florian

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 260 bytes
Desc: OpenPGP digital signature
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20091125/9ff064c8/attachment-0001.pgp>


More information about the drbd-user mailing list