[DRBD-user] 8.3.5 Stalling on sync

Mike Lovell mike at dev-zero.net
Wed Nov 25 17:01:19 CET 2009


nothing i tried tweaking in drbd.conf worked. the only thing that did 
was changing the 10gig interfaces. what cards are you using? i was using 
ones with an intel chip. the cards that i did get it to work with were 
from chelsio. in my previous thread on the list, someone mentioned that 
they had neterion cards working.

mike

James Larcombe wrote:
>
> Hi Mike,
>
>  
>
> Thanks for the quick response. Yes you are correct we are using 10gig 
> fibre cards. I'm not sure we could change them though as the fibre 
> modules used in them cost over £400 each.
>
>  
>
> Is there anything I can tweak in the drbd.conf file to get these to work.
>
>  
>
> James
>
>  
>
> *From:* Mike Lovell [mailto:mike at dev-zero.net]
> *Sent:* 24 November 2009 17:49
> *To:* James Larcombe
> *Cc:* drbd-user at lists.linbit.com
> *Subject:* Re: [DRBD-user] 8.3.5 Stalling on sync
>
>  
>
> James Larcombe wrote:
>
> Hi List,
>
>  
>
> Please help. I have installed drbd 8.3.5 on Open Suse 11.1 (Kernel 
> 2.6.27.29-0.1).
>
>  
>
> I have run drbdadm create-md dbms-test on one node and create-md 
> dbms-test2 on the other node. I then ran drbdadm up all on both nodes. 
> I then ran drbdadm -- --overwrite-data-of-my-peer primary dbms-test on 
> the first node and the same with dbms-test2 on the other node. They 
> then run for a short while before stalling. I have tried older version 
> without success and turning the sync rate down does not make any 
> difference. Downing the resources and bringing back up starts the sync 
> again but this then stalls quickly.
>
>  
>
> I have attached /proc/drbd, /etc/drbd.conf and a section from 
> /var/log/messages. Any pointers would be greatly appreciated.
>
>  
>
> version: 8.3.5 (api:88/proto:86-91)
>
> GIT-hash: ded8cdf09b0efa1460e8ce7a72327c60ff2210fb build by 
> root at hp-tm-40, 2009-11-24 12:21:46
>
>  0: cs:SyncSource ro:Secondary/Secondary ds:UpToDate/Inconsistent C r----
>
>     ns:160896 nr:0 dw:0 dr:160896 al:0 bm:9 lo:1 pe:0 ua:0 ap:0 ep:1 
> wo:b oos:926694296
>
>         [>.] sync'ed:  0.1% (905040/905132)M      4972
>
>         stalled
>
>  1: cs:SyncTarget ro:Secondary/Secondary ds:Inconsistent/UpToDate C r----
>
>     ns:0 nr:2173248 dw:2173248 dr:0 al:0 bm:132 lo:0 pe:29878 ua:0 
> ap:0 ep:1 wo:b oos:777971256
>
>         [>.] sync'ed:  0.3% (759736/761856)M
>
>         Stalled
>
>
> what kind of network are you using between the two servers? this is 
> almost the exact same behavior i had when i was trying to get drbd to 
> work over 10gig ethernet. turned out to be something in drbd didn't 
> like something about the 10gig cards i had. i eventually had to change 
> my network cards. what cards are you using? 1gig? 10gig? have you 
> tried other cards? that is where i would look.
>
> mike
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20091125/5d67ea97/attachment.htm>


More information about the drbd-user mailing list