[DRBD-user] drbd secondary stays 'inconsistent' if 'large' partition is created

Lars Ellenberg lars.ellenberg at linbit.com
Wed Sep 24 23:40:47 CEST 2008

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On Wed, Sep 24, 2008 at 08:47:36AM -0500, Kirby Bakken wrote:
> I have two identical systems, both with a RAID controller.  The first 'drive'
> is two 143GB SCSI drives, so there's 240GB or so combined storage.  If I create
> 'small' partitions on /dev/sda, drbd seems to work fine.  But when I create
> partitions that approach the actual size of the hard-disk, the syncer finishes,
> but the secondary drbd0 device stays 'inconsistent'.
> I've tried partitions of 8000 cylinders (that worked).  I just tried 140000,
> and it stays inconsistent..  (The actualy cylinder count is 140013).
> Here's the 140000 cylinder cound attempt that stayed inconstent:
> HELP!  What the heck is going on?

and you DRBD version is ... ?

did you consider to upgrade?
does it still happen with the latest release?

: Lars Ellenberg
: LINBIT | Your Way to High Availability
: DRBD/HA support and consulting http://www.linbit.com

DRBD® and LINBIT® are registered trademarks of LINBIT, Austria.
please don't Cc me, but send to list   --   I'm subscribed

More information about the drbd-user mailing list