[DRBD-user] Compatibility between two different versions of DRBD 0.7

Christophe Gras cgras at idfr.net
Mon Jun 2 15:38:14 CEST 2008


Hello,

We have a cluster of two nodes with Debian Sarge 3.1 ,  DRBD 0.7.10-4 
(debian packages), and Linux Kernel 2.6.8-2-686.
The primary node died due to a hard drive failure, and the second node 
becomes primary, no problem.

I want to reinstall the first node with newer packages (Debian Etch 4.0 
,  DRBD  0.7.21-4 (debian packages), linux kernel 2.6.18-4-686) and I 
wonder if 2 differents versions of DRBD 0.7 are compatible or not ?
I saw in the archives that DRBD 0.8 and DRBD 0.7 are not compatibles, 
but I found nothing in the user's guide about compatibility between 2 
versions of DRBD 0.7.

Besides, we recently had these errors with kernel 2.6.8-2 and need to 
reboot  :
"kernel: PREEMPT SMP
.....
kernel:  <6>note: nfsd[7325] exited with preempt_count 1"

I think these errors are due to a kernel problem with NFS server, and I 
wish to take advantage of the reinstallation of the died node in order 
to have a newer version of the Linux Kernel and DRBD.

Can I install Etch in my server or should I stay with Sarge ?

Thanks for your replies,

Regards,

Christophe Gras




More information about the drbd-user mailing list