[DRBD-user] primary/secondary problem

Gernot W. Schmied gernot.schmied at chello.at
Sun Jun 11 23:22:38 CEST 2006


Hi,

Since my migration (didn't change a thing!) to newest Ubuntu my DRBD
setup (0.7.17 on both machines) on my primary machine suddenly insists
to remain in "secondary" mode. Any idea why?

Thanks,
Gernot


root at centauri:/usr/lib# /etc/init.d/drbd status
drbd driver loaded OK; device status:
version: 0.7.17 (api:77/proto:74)
SVN Revision: 2093 build by root at centauri, 2006-06-11 16:32:17
 0: cs:WFConnection st:Secondary/Unknown ld:Consistent
    ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0
 1: cs:WFConnection st:Secondary/Unknown ld:Consistent
    ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0
root at centauri:/usr/lib# drbdadm primary all
root at centauri:/usr/lib# /etc/init.d/drbd status
drbd driver loaded OK; device status:
version: 0.7.17 (api:77/proto:74)
SVN Revision: 2093 build by root at centauri, 2006-06-11 16:32:17
 0: cs:WFConnection st:Primary/Unknown ld:Consistent
    ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0
 1: cs:WFConnection st:Primary/Unknown ld:Consistent
    ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0
root at centauri:/usr/lib# /etc/init.d/drbd stop
Stopping all DRBD resourcesunmounting disks, Stopping all DRBD resources
.
root at centauri:/usr/lib# /etc/init.d/drbd status
drbd not loaded
root at centauri:/usr/lib# /etc/init.d/drbd start
Starting DRBD resources:    [ d0 d1 s0 s1 n0 n1 ].
root at centauri:/usr/lib# /etc/init.d/drbd status
drbd driver loaded OK; device status:
version: 0.7.17 (api:77/proto:74)
SVN Revision: 2093 build by root at centauri, 2006-06-11 16:32:17
 0: cs:WFConnection st:Secondary/Unknown ld:Consistent
    ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0
 1: cs:WFConnection st:Secondary/Unknown ld:Consistent
    ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0



More information about the drbd-user mailing list