[DRBD-user] NegRSDReply. WE ARE LOST

Jon Schutz jon.drbd at YourAmigo.com
Wed Mar 23 03:18:43 CET 2005


Hi,

I am getting the following error while syncing:

Kernel panic: drbd0: Got NegRSDReply. WE ARE LOST. We lost our
up-to-date disk.

and so far all of my attempts to fix it have failed. 

This is the history:

- The primary server failed and the backup took over

- When the primary server was restored, the syncing started from the
backup to the restored primary, followed by this error, mostly near the
end of the syncing process (95%-98%).

- I tried fsck -f -y /dev/drbd0 on both ends.  On first attempt, I had
the error that the filesystem size was larger than the physical size. 
Not sure how this happened, as I'm sure I put the filesystem on the drbd
device and not the raw device, but regardless, I resized the underlying
filesystem and restarted the drbd device and the fsck found a couple of
problems and otherwise went OK.  But the NegRSDReply persisted.

- I tried fsck -c -f -y /dev/drbd0 to search for bad blocks on the sync
source end.  It took forever near the end of the disk.  Now I still get
the same NegRSDReply problem, but it is happening much earlier in the
syncing process.

A second drbd drive on the same cluster has resynced just fine.

Any suggestions as to how I can resolve this?

Thanks,

-- 

Jon




More information about the drbd-user mailing list