[DRBD-user] Permission Denied

Colin Bruce ccx004 at coventry.ac.uk
Fri Jun 25 21:26:13 CEST 2004


Dear All,

We have been running drbd on several systems for over a year but today
I can't get it to go on a couple of test systems which are just a pair
of old PCs. I type

    drbdsetup /dev/nb0 disk /dev/hda5

and get

    ioctl() failed: Permission denied
    No further Information available.

I can't find anything about this other than some people making jokes on
the mailing list about it. Presumably they know what is wrong.

I am running the same kernel on these systems as I run on the production
systems (2.4.25). I have NFS mounted the kernel sources on these test machines
so I know I am using the same configuration. The .config files are there.
I have built and tested drbd version 0.6.1 through to 0.6.9 (missing a couple
out on the way) but they all do the same thing. As I do this it is happily
running on other machines although they are proper servers with SCSI
interfaces. I can't believe drbd requires SCSI?

The drbd.conf file is about as basic as it gets. Just one partition
mirrored to the other server. I can't think what more to say. Oh yes,
I am logged in as root, I have deleted nb0 and recreated it. I have mounted
the disk as /dev/hda5 and it still doesn't work.

Does anyone know how to fix this please?

Best wishes....
Colin




More information about the drbd-user mailing list