[DRBD-user] Opteron/Xeon - Kernel 2.4/2.6 setup

Eugene Crosser crosser at rol.ru
Tue Jun 15 09:57:46 CEST 2004


On Mon, 2004-06-14 at 09:51 +0200, Lars Ellenberg wrote:

> > I saw that the 0.7 branch should work on kernel 2.6.
> > But would it be crazy to use this in a production environment?
> 
> currently that would be asking for trouble.
> we have indication that under some circumstances drbd 0.7 may still
> cause data inconsistencies between its mirrors [read data corruption] :(

It was me who provided said indication.
I've got a (crasy?) thought: could that inconsistency be caused by
initially wrong meta-disk information, that does not get fully refreshed
after "invalidate"?  The point is that I had switched between 0.6 and
0.7 several times, and every time I changed 0.6 to 0.7, meta-disk
naturally was out-of-sync with the actual data.  Of course I ran
"invalidate" every time, but maybe it is not sufficient?

Eugene
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.linbit.com/pipermail/drbd-user/attachments/20040615/9e911f72/attachment.pgp 


More information about the drbd-user mailing list