[drbd-mc] Cannot add extra IDE CD-ROM to VM + more issues

Rasto Levrinc rasto.levrinc at gmail.com
Sat Jul 28 21:07:16 CEST 2012

On Mon, Jul 23, 2012 at 11:57 AM, Caspar Smit <c.smit at truebit.nl> wrote:
> 2012/7/23 Rasto Levrinc <rasto.levrinc at gmail.com>:
>> On Thu, Jul 19, 2012 at 2:50 PM, Caspar Smit <c.smit at truebit.nl> wrote:
>>> Hi Rasto,
>>> -After creating a VM I'd like to add another ISO as IDE CD-ROM to the
>>> VM through Add disk while the VM is running.
>>> 1) Click on Add disk
>>> 2) Select Image File
>>> 3) Disk Type IDE CD-ROM
>>> 4) Now I cannot select the target device (only selectable is <<nothing
>>> selected>>)
>>> Applying ends in error and using IDE DISK instead doesn;t work because
>>> it doesn't take the ISO file as disk.
>> Hi Caspar,
>> Somehow it was assumed there's only one CD drive.
>> I've made the field editable:
>> http://sourceforge.net/projects/lcmc/files/testing/
> Hi Rasto,
> Ok, the field is now editable but when add a new disk and enter:
> Type: Image File
> Disk type: IDE CD-ROM
> Target device: /dev/hdd (unused)
> Source file: /etc/blah.iso
> Driver name: qemu
> Readonly: yes
> And apply i get: Failed to define domain from /etc/libvirt/qemu/debtest.xml.new
> Error: Unknown failure.
> When I then select the new disk in the left frame under VMs (KVM, Xen)
> it is detected as /dev/hdc (The first CD-ROM drive) so I guess a
> conflict somewhere?

there was a bug, now fixed here

The tree menu wouldn't be reloaded and cause the subsequent confusion.

>>> More issues:
>>> -Disconnect and connect to a cluster clears all VM info (need to quit
>>> LCMC and restart to get it working again).
>> Not sure how to reproduce this one. Which VM info do you mean?
> I created a VM using LCMC, the domain name is listed under VMs (KVM, Xen).
> When I click disconnect i go to the LCMC 'home' screen again, now when
> i click the same cluster again to re-connect the virtual domain under
> VMs (KVM, Xen) is gone.

Ah, now I could reproduce it, will be fixed.

>>> -Is it possible to refresh the mouse cursor more accurately when
>>> viewing the console for a VM from within LCMC, I have LOADS of
>>> difficulty selecting buttons/menus because the underlying mouse cursor
>>> is already 'offscreen' this is VERY frustrating.
>> You can make tablet instead of mouse device, to avoid this problem.
> Ok, i tried to add a tablet device which worked. But I could not
> remove the mouse device (it keeps re-appearing).
> I stopped the VM
> Added the tablet
> Clicked on remove device for the mouse. (It got removed on the left
> frame under VMs (KVM, Xen), but remains on the right frame where i
> clicked remove device)
> Start the VM again
> The mouse re-appears on the left frame under VMs (KVM, Xen)!

It's not possible to remove the "ps" mouse, but once you add the tablet,
that's what will be used, after the VM restart, so that should solve the

> PS. I have the same problem when removing disks.

It's not the same problem, it's the menu reloading bug when
adding/removing disks.

> Btw, is there a way to add/remove hardware while the VM is running? I
> now shutdown the VM to add/remove hardware.

It's not possible at the moment with LCMC.

> Another question, is there a way to easily add the created VM using
> LCMC to the CRM/pacemaker config?
> So after creation click a button like "make highly available" so that
> LCMC creates a VirtualDomain primitive resource for it?

Sounds like a good Idea, now you can only switch to the Pacemaker view
and add VirtualDomain there, there are some pulldown menus though to
make it easier to configure.


Dipl.-Ing. Rastislav Levrinc
rasto.levrinc at gmail.com
Linux Cluster Management Console

More information about the drbd-mc mailing list