[drbd-mc] Cannot add extra IDE CD-ROM to VM + more issues

Caspar Smit c.smit at truebit.nl
Mon Jul 23 11:57:32 CEST 2012

2012/7/23 Rasto Levrinc <rasto.levrinc at gmail.com>:
> On Thu, Jul 19, 2012 at 2:50 PM, Caspar Smit <c.smit at truebit.nl> wrote:
>> Hi Rasto,
>> -After creating a VM I'd like to add another ISO as IDE CD-ROM to the
>> VM through Add disk while the VM is running.
>> 1) Click on Add disk
>> 2) Select Image File
>> 3) Disk Type IDE CD-ROM
>> 4) Now I cannot select the target device (only selectable is <<nothing
>> selected>>)
>> Applying ends in error and using IDE DISK instead doesn;t work because
>> it doesn't take the ISO file as disk.
> Hi Caspar,
> Somehow it was assumed there's only one CD drive.
> I've made the field editable:
> http://sourceforge.net/projects/lcmc/files/testing/

Hi Rasto,

Ok, the field is now editable but when add a new disk and enter:

Type: Image File
Disk type: IDE CD-ROM
Target device: /dev/hdd (unused)
Source file: /etc/blah.iso
Driver name: qemu
Readonly: yes

And apply i get: Failed to define domain from /etc/libvirt/qemu/debtest.xml.new
Error: Unknown failure.

When I then select the new disk in the left frame under VMs (KVM, Xen)
it is detected as /dev/hdc (The first CD-ROM drive) so I guess a
conflict somewhere?

>> More issues:
>> -Disconnect and connect to a cluster clears all VM info (need to quit
>> LCMC and restart to get it working again).
> Not sure how to reproduce this one. Which VM info do you mean?

I created a VM using LCMC, the domain name is listed under VMs (KVM, Xen).
When I click disconnect i go to the LCMC 'home' screen again, now when
i click the same cluster again to re-connect the virtual domain under
VMs (KVM, Xen) is gone.

>> -Is it possible to refresh the mouse cursor more accurately when
>> viewing the console for a VM from within LCMC, I have LOADS of
>> difficulty selecting buttons/menus because the underlying mouse cursor
>> is already 'offscreen' this is VERY frustrating.
> You can make tablet instead of mouse device, to avoid this problem.

Ok, i tried to add a tablet device which worked. But I could not
remove the mouse device (it keeps re-appearing).

I stopped the VM
Added the tablet
Clicked on remove device for the mouse. (It got removed on the left
frame under VMs (KVM, Xen), but remains on the right frame where i
clicked remove device)
Start the VM again
The mouse re-appears on the left frame under VMs (KVM, Xen)!

PS. I have the same problem when removing disks.

Btw, is there a way to add/remove hardware while the VM is running? I
now shutdown the VM to add/remove hardware.

Another question, is there a way to easily add the created VM using
LCMC to the CRM/pacemaker config?
So after creation click a button like "make highly available" so that
LCMC creates a VirtualDomain primitive resource for it?

Kind regards,

>> -When I shutdown a VM from the VNC console, the console stays 'active'
>> even if the VM has shut down, it would be nice if the console is
>> closed when the VM has shutdown.
> I've put that on my TODO list.
> Thanks,
> Rasto
> --
> Dipl.-Ing. Rastislav Levrinc
> rasto.levrinc at gmail.com
> Linux Cluster Management Console
> http://lcmc.sf.net/
> _______________________________________________
> drbd-mc mailing list
> drbd-mc at lists.linbit.com
> http://lists.linbit.com/mailman/listinfo/drbd-mc

More information about the drbd-mc mailing list