[drbd-mc] Announce: LCMC 1.3.0 / Pacemaker, DRBD, KVM GUI

Caspar Smit c.smit at truebit.nl
Tue Feb 28 21:08:17 CET 2012


Thank you very much for your explanations, it cleared a lot.

I didn't know the split brain resolution was only available in
advanced mode, thanks now it works :)

Kind regards,

Caspar Smit

Op 28 februari 2012 21:02 heeft Rasto Levrinc
<rasto.levrinc at gmail.com> het volgende geschreven:
> On Mon, Feb 27, 2012 at 3:49 PM, Caspar Smit <c.smit at truebit.nl> wrote:
>> Hi Rasto,
>> I checked the new LCMC version today and found out some stuff again.
>> 1) I cannot right-click on resources/groups in the graphical display
>> anymore to get the sub-menu. Not even on the hosts.
>>   It is only possible to right click on the resource/group names in
>> the left window (under CRM pacemaker)
>>   Is this a 'feature' or a 'bug' ?
> Hi Caspar,
> it's a bug that effects Windows users, so I got a lot of reports about
> that. I've just fixed that, so later today there'll be 1.3.1 version.
>> 2) Everytime I connect to a cluster I get a big red <cluster name>:
>> Cluster status failed scrolling but after that the cluster seems fine.
>> This is when using sudo and root.
> Yup, will be fixed, it's a cosmetic problem.
>> 3) disconnecting from a cluster doesn't really disconnect because when
>> I disconnect from a cluster and connect another cluster it still does
>> some status updates for the disconnected cluster (I get an: updating
>> drbd/cluster status from the disconnected cluster(s), and that some
>> clusters don't even have drbd installed and this takes a lot of time).
>> how can i really disconnect the cluster(s) without leaving LCMC?
> This is because of the effort to reduce the number ssh connections. At
> the moment you can only kill these processes on the server, until I fix
> it.
>> 4) I found out today I had a split-brain cluster and I noticed that
>> the pacemaker Master/slave resource had no problem and "all is fine"
>> Primary/Secondary etc... I tried resolving this through LCMC (DRBD)
>> but all my options were greyed out for doing anything to the DRBD
>> resources. Using sudo and root didn't make a difference. Any idea why?
> Pacemaker can't do anything in this case with the resource. You should
> inspect why you had the split-brain, maybe you're missing some
> configuration.
> To find out if you have split-brain from the GUI, you have to connect
> the disconnected resource, it will not connect but it will detect that
> it has a split brain. Connecting is enabled (if it is used by Pacemaker)
> only in advanced mode. The GUI gets message that there's a split-brain
> and offers the split-brain resolution dialog.
>> 5) Can you explain the "workaround for iSCSITarget RA" ? I'm using a
>> cluster with that RA but nothing seems changed.
> It shouldn't effect you at all. There is some remote possibility that
> default for "iSCSI Target implementation" could be wrong. There was also
> a "status " with space in the meta-data, that could get stored in the
> CIB. It would be ignored. You should check if you have it and remove it.
>> 6) What does the "disable one-host cluster by default" exactly do
>> because I can still add 1 host, and then a cluster with that 1 host
>> (and this is something I would still like to able to do if
>> nessessary).
> there's a --one-host-cluster option for the old functionality now. It
> was disabled by default because someone could define one host cluster by
> mistake and destroy the existing two-node DRBD configuration.
> thanks,
> Rasto
> --
> Dipl.-Ing. Rastislav Levrinc
> rasto.levrinc at gmail.com
> Linux Cluster Management Console
> http://lcmc.sf.net/
> _______________________________________________
> drbd-mc mailing list
> drbd-mc at lists.linbit.com
> http://lists.linbit.com/mailman/listinfo/drbd-mc

More information about the drbd-mc mailing list