[Drbd-dev] [PATCH v3 07/16] block: Rename bio_split() -> bio_pair_split()

Boaz Harrosh bharrosh at panasas.com
Mon May 28 12:15:39 CEST 2012


On 05/25/2012 11:25 PM, Kent Overstreet wrote:

> This is prep work for introducing a more general bio_split()
> 
> Change-Id: Ib9c4ff691af889d26bc9ec9fb42a2f3068f34ad9
> 


Since these patches will go through Jens tree this kind of
comment can *never* be true/correct. And it is plenty unwanted
for sure.

Here:
bio_do means an operation on bio. But here we are actually operating
on a bio_pair. So rename it it to bio_pair_do.

We will later introduce a real bio_split() function that receives
a bio and splits it.

Or something like that.
Thanks
Boaz

> Signed-off-by: Kent Overstreet <koverstreet at google.com>

<snip>

> @@ -201,7 +201,7 @@ struct bio_pair {
>  	atomic_t			cnt;
>  	int				error;
>  };
> -extern struct bio_pair *bio_split(struct bio *bi, int first_sectors);
> +extern struct bio_pair *bio_pair_split(struct bio *bi, int first_sectors);
>  extern void bio_pair_release(struct bio_pair *dbio);
>  
>  extern struct bio_set *bioset_create(unsigned int, unsigned int);




More information about the drbd-dev mailing list